Linux/Python学习论坛-京峰教育

 找回密码
 立即注册

一键登录:

搜索
热搜: 活动 交友 discuz
查看: 1403|回复: 8

只要一开iptables就连不上ftp

[复制链接]

2

主题

20

帖子

373

积分

中级会员

Rank: 3Rank: 3

积分
373
QQ
发表于 2015-6-22 22:00:10 | 显示全部楼层 |阅读模式
getenforce
Disabled

状态:    已连接
状态:    读取目录列表...
命令:    PWD
响应:    257 "/home/tongwei"
命令:    TYPE I
响应:    200 Switching to Binary mode.
命令:    PASV
响应:    227 Entering Passive Mode (172,16,10,10,139,41).
命令:    LIST
错误:    Connection timed out after 20 seconds of inactivity
错误:    读取目录列表失败

iptables stop就ok

下面是iptables内容
cat /etc/sysconfig/iptables
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [4:496]
-A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT
-A INPUT -p tcp -m state --state NEW -m tcp --dport 21 -j ACCEPT
-A INPUT -p tcp -m state --state NEW -m tcp --dport 20 -j ACCEPT
-A INPUT -j REJECT --reject-with icmp-host-prohibited
-A FORWARD -j REJECT --reject-with icmp-host-prohibited
COMMIT

回复

使用道具 举报

0

主题

31

帖子

1020

积分

新手上路

Rank: 1

积分
1020
发表于 2015-6-22 22:10:54 | 显示全部楼层
你防火墙配置只有input没有output,这样仍然是不能通过ftp服务的
回复 支持 反对

使用道具 举报

2

主题

20

帖子

373

积分

中级会员

Rank: 3Rank: 3

积分
373
QQ
 楼主| 发表于 2015-6-22 22:12:14 | 显示全部楼层
什么意思
回复

使用道具 举报

2

主题

20

帖子

373

积分

中级会员

Rank: 3Rank: 3

积分
373
QQ
 楼主| 发表于 2015-6-22 22:28:36 | 显示全部楼层
我把iptables停了
连接后再看
[root@centos ~]# /etc/init.d/iptables stop
iptables: Setting chains to policy ACCEPT: filter          [  OK  ]
iptables: Flushing firewall rules:                         [  OK  ]
iptables: Unloading modules:                               [  OK  ]

[root@centos ~]# netstat -an | grep 21
tcp        0      0 0.0.0.0:21                  0.0.0.0:*                   LISTEN      
tcp        0      0 172.16.10.10:21             172.16.3.51:53647           ESTABLISHED
unix  3      [ ]         STREAM     CONNECTED     10721  
回复 支持 反对

使用道具 举报

2

主题

20

帖子

373

积分

中级会员

Rank: 3Rank: 3

积分
373
QQ
 楼主| 发表于 2015-6-22 22:41:52 | 显示全部楼层
但iptables一开,就会出问题,麻烦哪位老大看看
回复 支持 反对

使用道具 举报

2

主题

20

帖子

373

积分

中级会员

Rank: 3Rank: 3

积分
373
QQ
 楼主| 发表于 2015-6-23 22:23:58 | 显示全部楼层
这个没人回,没人指导,还不如删了呢
回复 支持 反对

使用道具 举报

2

主题

20

帖子

373

积分

中级会员

Rank: 3Rank: 3

积分
373
QQ
 楼主| 发表于 2015-6-23 22:28:25 | 显示全部楼层
竟然没人回答,竟然连自己的贴都无法删除
回复 支持 反对

使用道具 举报

217

主题

331

帖子

4642

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
4642
QQ
发表于 2015-6-23 22:37:44 | 显示全部楼层
开启被动模式FTP支持:
在/etc/sysconfig/iptables-config里面添加ip_nat_ftp、ip_conntrack_ftp模块,如下:
vim /etc/sysconfig/iptables-config
IPTABLES_MODULES="ip_nat_ftp"
IPTABLES_MODULES="ip_conntrack_ftp"
然后重启iptables或者执行如下命令:
lsmod | grep ftp (查看是否加载ftp模块)
modprobe ip_nat_ftp(加载ftp模块)
lsmod | grep ftp (查看模块是否被加载)
之后只需要添加规则
iptables -I INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A INPUT -m state --state NEW -p tcp --dport 21 -j ACCEPT
京峰Linux教育创始人之一,只为有梦想的人!任何事情只要去行动,就会收获结果!
回复 支持 反对

使用道具 举报

2

主题

20

帖子

373

积分

中级会员

Rank: 3Rank: 3

积分
373
QQ
 楼主| 发表于 2015-6-23 23:06:19 | 显示全部楼层
恩,这个完美!
再加个service iptables save
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|小黑屋|京峰教育,只为有梦想的人 ( 京ICP备15013173号 )

GMT+8, 2019-1-22 22:08 , Processed in 0.038971 second(s), 16 queries , Apc On.

快速回复 返回顶部 返回列表