Linux/Python学习论坛-京峰教育

 找回密码
 立即注册

一键登录:

搜索
热搜: 活动 交友 discuz
查看: 835|回复: 0

Centos6.x系统安装后的优化

[复制链接]

203

主题

267

帖子

2295

积分

超级版主

Rank: 8Rank: 8

积分
2295
发表于 2015-3-21 22:58:36 | 显示全部楼层 |阅读模式
本帖最后由 姜伟 于 2015-3-23 11:36 编辑

(1)查看系统版本信息:
[root@localhost ~]# cat /etc/redhat-release
CentOS release 6.4 (Final)
(2)为centos6.4添加epel源:
[root@localhost ~]#wget
http://ftp.riken.jp/Linux/fedora ... ease-6-8.noarch.rpm
[root@localhost ~]#rpm -ivh epel-release-6-8.noarch.rpm
warning: /var/tmp/rpm-tmp.mgMNYU: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY
Preparing...                ########################################### [100%]
   1:epel-release           ########################################### [100%]
(3)修改字符集为英文,避免安装过程中出项不必要的错误而浪费编译时间进而影响工作效率:修改之后重新登录即可生效。
或者使用下面的命令立即生效
[root@localhost ~]# source /etc/sysconfig/i18n
[root@localhost ~]# vim /etc/sysconfig/i18n
LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"
临时修改为[root@localhost ~]# export LANG=en
(4)安装Yum加速组件
[root@localhost ~]#yum -y install yum-fastestmirror
[root@localhost ~]# yum repolist
[root@localhost ~]# yum clean all
Loaded plugins: fastestmirror, security
Cleaning repos: base epel extras updates
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@localhost ~]# yum makecache #重新生成元数据,防止依赖关系被损坏

(5)安装编译软件等所需开发工具包组,记得包组要用英文下的双引号引起来,因为中间有空格,你还记得吗?shell里面用空格的时候会怎样?呵呵
[root@localhost ~]# yum -y groupinstall "Desktop Platform Development" "Development tools"  "Server Platform Development"
若是之前已经安装了也是需要进行这一步的,因为它会把系统自身需要的软件包更新到最新,从而进一步防止系统漏洞,这可是线上经验哦!这一步很有必要,因为前面做的epel源就是为此服务的哦!

(6)yum安装系统所需的必要工具
安装编译LAMP所需各种小工具gcc gcc-c++make automake autoconf kernel-devel
安装PHP所需依赖,如libxml2-devel openssl-devel curl-devel libjpeg-devel libpng-devel等。
[root@localhost ~]#  yum -y install gcc gcc-c++ kernel-devel ntp vim-enhanced flex bison autoconf make automake bzip2-devel ncurses-devel zlib-devel libjpeg-devel libpng-devel libtiff-devel freetype-devel libXpm-devel gettext-devel  pam-devel libtool libtool-ltdl openssl openssl-devel fontconfig-devel libxml2-devel curl-devel  libicu libicu-devel libmcrypt libmcrypt-devel libmhash libmhash-devel pcre-devel libtool-libs gd file patch mlocate diffutils readline-devel glibc-devel glib2-devel libcap-devel
(7) 在编译安装LAMP之前,首先先卸载已存在的rpm包
首先是检查各个软件是否安装
[root@localhost ~]# rpm -q httpd
package httpd is not installed
[root@localhost ~]# rpm -q mysql
package mysql is not installed
[root@localhost ~]# rpm -q  php
package php is not installed
使用yum或rpm工具卸载系统曾经安装的lamp软件
rpm -e httpd
rpm -e mysql
rpm -e php
yum -y remove httpd
yum -y remove mysql-server mysql
yum -y remove php
yum -y remove php-mysql
(8)禁用SeLinux selinux可能会致使编译安装失败,我们先禁用它
[root@localhost ~]# setenforce 0
[root@localhost ~]# getenforce
Permissive
[root@localhost ~]# sed -i s/SELINUX=enforcing/SELINUX=disabled/g /etc/sysconfig/selinux   #永久禁用,需要重启生效。
[root@localhost ~]# grep ^SELINUX /etc/sysconfig/selinux
SELINUX=disabled
SELINUXTYPE=targeted
(9)开机启动优化,服务最小化原则
本着服务最小化的原则,本实例安装LAMP也正是为了此目的,关闭一切不需要的服务,目前只开放以下几个服务。
======>清理开机自启动的服务
思路:1>通过脚本关闭全部的服务
[root@localhost ~]# for test in `chkconfig --list |grep 3: on|awk '{print $1}'`;do chkconfig --level 3 $ test off;done
          2>执行下面的命令开启需要开机启动的服务
[root@localhost ~]# for test in crond network rsyslog sshd;do chkconfig --level 3 $ test on;done          3>优化后的结果是自己想要的吗?
      [root@localhost ~]# chkconfig --list |grep 3: on

总之就是一个原则,服务器最小化服务原则,强调专一的力量的重要性


最后再安装系统的常用命令:
[root@localhost ~]# yum -y install vim-enhanced wget lrzsz

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|小黑屋|京峰教育,只为有梦想的人 ( 京ICP备15013173号 )

GMT+8, 2020-2-26 20:25 , Processed in 0.023040 second(s), 12 queries , Redis On.

快速回复 返回顶部 返回列表